[PATCH] D27872: [APFloat] Switch from (PPCDoubleDoubleImpl, IEEEdouble) layout to (IEEEdouble, IEEEdouble)
Tim Shen via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed Jan 4 15:23:15 PST 2017
timshen added a comment.
In https://reviews.llvm.org/D27872#636130, @echristo wrote:
> Looks pretty weird. Typically I'd suggest just:
>
> if (foo) {
>
> Foo();
> return;
>
> }
>
> since that will keep cognitive overhead to a minimum.
>
> -eric
>
> > Other functions are not controversial.
I'm happy to discuss on a style guide <del>bikeshedding</del>change, since you are the second person that raises this concern, and now it's like 2 vs 2 :).
Another reason to not to do so is consistency with other returning functions, and potential changes required in the future, when a void-returning function starts to return values.
https://reviews.llvm.org/D27872
More information about the cfe-commits
mailing list