[PATCH] D26511: [clang-tidy] Rename modernize-use-default to modernize-use-equals-default
Aaron Ballman via cfe-commits
cfe-commits at lists.llvm.org
Thu Nov 10 09:19:40 PST 2016
aaron.ballman added inline comments.
================
Comment at: clang-tidy/modernize/ModernizeTidyModule.cpp:58
"modernize-use-bool-literals");
- CheckFactories.registerCheck<UseDefaultCheck>("modernize-use-default");
+ CheckFactories.registerCheck<UseEqualsDefaultCheck>("modernize-use-equals-default");
CheckFactories.registerCheck<UseEmplaceCheck>("modernize-use-emplace");
----------------
What do we want to do, if anything, for people who have scripts using the old name? Do we want to keep the old name as an alias to the new name for some period of time?
https://reviews.llvm.org/D26511
More information about the cfe-commits
mailing list