[PATCH] D24893: [clang-tidy] make readability-redundant-smartptr-get report get() usage in conditions

Kirill Bobyrev via cfe-commits cfe-commits at lists.llvm.org
Sun Sep 25 03:07:43 PDT 2016


omtcyfz updated this revision to Diff 72422.
omtcyfz marked an inline comment as done.
omtcyfz added a comment.

Replace `anyOf(hasName("..."), hasName("..."))` with `hasAnyName("...", "...")`.


https://reviews.llvm.org/D24893

Files:
  clang-tidy/readability/RedundantSmartptrGetCheck.cpp
  test/clang-tidy/readability-redundant-smartptr-get.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D24893.72422.patch
Type: text/x-patch
Size: 4221 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20160925/60e24e17/attachment.bin>


More information about the cfe-commits mailing list