[PATCH] D23198: clang-rename rename-all: support reading old/newname pairs from a YAML file
Kirill Bobyrev via cfe-commits
cfe-commits at lists.llvm.org
Fri Aug 5 06:46:15 PDT 2016
omtcyfz added inline comments.
================
Comment at: clang-rename/tool/ClangRename.cpp:140
@@ -116,1 +139,3 @@
cl::value_desc("filename"), cl::cat(*Category));
+ cl::opt<std::string> Input(
+ "input", cl::desc("YAML file to load oldname-newname pairs from."),
----------------
vmiklos wrote:
> omtcyfz wrote:
> > "Input" name doesn't make sense to me here.
> When you feed a YAML file into include-fixer, the argument name is `-input`, that's what I copied. What about `-names`?
Hm. That's true, `include-fixer` calls it the same. Well, then it'd be okay to let it be `-input`, so that it's more uniform across the tools.
https://reviews.llvm.org/D23198
More information about the cfe-commits
mailing list