[PATCH] D21472: [clang-tidy] readability-identifier-naming - support for other case types
Alexander Kornienko via cfe-commits
cfe-commits at lists.llvm.org
Tue Jul 5 15:57:28 PDT 2016
alexfh added a comment.
In http://reviews.llvm.org/D21472#473813, @JamesReynolds wrote:
> Ah, I took this from a single example in the CPP core guidelines - that PDF is indeed a very different style. An idea we toyed with was "UpperSeparated" and "UpperSeparatedBack"? Would that work?
You mean Upper_Separated and upper_Separated_Back? ;) Actually, these names are not particularly clear. I've managed to find "Camel_Snake_Case" used for exactly this naming convention (in the https://github.com/t6/camel_snake_kebab library). Maybe "camel_Snake_Back" as well?
> This comes from ...
I just wanted to hear that this is actually going to be used. No objections.
http://reviews.llvm.org/D21472
More information about the cfe-commits
mailing list