[PATCH] D19763: Functions declared in a scope should not hide previous declaration in earlier scopes

Richard Smith via cfe-commits cfe-commits at lists.llvm.org
Thu Jun 16 12:07:54 PDT 2016


rsmith accepted this revision.
This revision is now accepted and ready to land.

================
Comment at: lib/Sema/SemaLookup.cpp:1091
@@ -1091,2 +1091,2 @@
     bool Found = false;
     for (; I != IEnd && S->isDeclScope(*I); ++I) {
----------------
Please rename this to something like `SearchNamespaceScope` (and invert the sense of it) to reflect what it now means.


http://reviews.llvm.org/D19763





More information about the cfe-commits mailing list