[PATCH] D21020: [clang-tidy] readability-identifier-naming - Support for Macros

Alexander Kornienko via cfe-commits cfe-commits at lists.llvm.org
Thu Jun 16 09:39:58 PDT 2016


alexfh accepted this revision.
alexfh added a comment.
This revision is now accepted and ready to land.

Looks good with a couple of nits.


================
Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:808
@@ +807,3 @@
+  addUsage(NamingCheckFailures, ID, Range);
+  return;
+}
----------------
`return`?

================
Comment at: clang-tidy/readability/IdentifierNamingCheck.h:94
@@ -86,1 +93,3 @@
 
+  /// Check Macros for style violations
+  void checkMacro(SourceManager &sourceMgr, const Token &MacroNameTok,
----------------
Please add trailing periods to comments. See also http://llvm.org/docs/CodingStandards.html#commenting


http://reviews.llvm.org/D21020





More information about the cfe-commits mailing list