[PATCH] D19770: Add FixedSizeStorage to TrailingObjects; NFC

Hubert Tong via cfe-commits cfe-commits at lists.llvm.org
Sat Apr 30 15:23:16 PDT 2016


hubert.reinterpretcast added a comment.

An example of using `FixedSizeStorage` can be found in http://reviews.llvm.org/D19771.


================
Comment at: include/llvm/Support/TrailingObjects.h:352
@@ +351,3 @@
+    template <size_t... Counts>
+    using _ =
+        llvm::AlignedCharArray<trailing_objects_internal::AlignmentCalcHelper<
----------------
I named the member, `_`, as such, because I found that having a longer or more meaningful name (such as `with_counts`) here causes "noise" at the point where the type is used.


http://reviews.llvm.org/D19770





More information about the cfe-commits mailing list