[PATCH] D18442: A clang-tidy check for std:accumulate.

Clement Courbet via cfe-commits cfe-commits at lists.llvm.org
Mon Apr 25 04:42:46 PDT 2016


courbet added inline comments.

================
Comment at: clang-tidy/misc/FoldInitTypeCheck.cpp:89
@@ +88,3 @@
+
+/// Returns true if ValueType is allowed to fold into InitType, i.e. if:
+///   static_cast<InitType>(ValueType{some_value})
----------------
alexfh wrote:
> Is "fold" a commonly used term in this context? At least, it's not a language standard jargon and not something I heard of frequently. Maybe we should try to find a more clear word?
The terminology is from functional programming (https://en.wikipedia.org/wiki/Fold_(higher-order_function)), I don't really have a better name for these. Do you have anything to suggest ?


http://reviews.llvm.org/D18442





More information about the cfe-commits mailing list