[clang-tools-extra] r266734 - [clang-tidy] readability-container-size-empty fixes
Gabor Horvath via cfe-commits
cfe-commits at lists.llvm.org
Tue Apr 19 06:29:06 PDT 2016
Author: xazax
Date: Tue Apr 19 08:29:05 2016
New Revision: 266734
URL: http://llvm.org/viewvc/llvm-project?rev=266734&view=rev
Log:
[clang-tidy] readability-container-size-empty fixes
Summary: This patch fixes PR27410 and adds std::basic_string support.
Reviewers: Eugene.Zelenko, hokein
Subscribers: cfe-commits, o.gyorgy
Differential Revision: http://reviews.llvm.org/D19262
Modified:
clang-tools-extra/trunk/clang-tidy/readability/ContainerSizeEmptyCheck.cpp
clang-tools-extra/trunk/test/clang-tidy/readability-container-size-empty.cpp
Modified: clang-tools-extra/trunk/clang-tidy/readability/ContainerSizeEmptyCheck.cpp
URL: http://llvm.org/viewvc/llvm-project/clang-tools-extra/trunk/clang-tidy/readability/ContainerSizeEmptyCheck.cpp?rev=266734&r1=266733&r2=266734&view=diff
==============================================================================
--- clang-tools-extra/trunk/clang-tidy/readability/ContainerSizeEmptyCheck.cpp (original)
+++ clang-tools-extra/trunk/clang-tidy/readability/ContainerSizeEmptyCheck.cpp Tue Apr 19 08:29:05 2016
@@ -16,6 +16,7 @@ using namespace clang::ast_matchers;
static bool isContainerName(llvm::StringRef ClassName) {
static const char *const ContainerNames[] = {"array",
+ "basic_string",
"deque",
"forward_list",
"list",
@@ -59,14 +60,13 @@ void ContainerSizeEmptyCheck::registerMa
return;
const auto WrongUse = anyOf(
- hasParent(
- binaryOperator(
- anyOf(has(integerLiteral(equals(0))),
- allOf(anyOf(hasOperatorName("<"), hasOperatorName(">="),
- hasOperatorName(">"), hasOperatorName("<=")),
- hasEitherOperand(
- ignoringImpCasts(integerLiteral(equals(1)))))))
- .bind("SizeBinaryOp")),
+ hasParent(binaryOperator(
+ anyOf(hasOperatorName("<"), hasOperatorName(">="),
+ hasOperatorName(">"), hasOperatorName("<="),
+ hasOperatorName("=="), hasOperatorName("!=")),
+ hasEitherOperand(ignoringImpCasts(anyOf(
+ integerLiteral(equals(1)), integerLiteral(equals(0))))))
+ .bind("SizeBinaryOp")),
hasParent(implicitCastExpr(
hasImplicitDestinationType(booleanType()),
anyOf(
@@ -122,6 +122,10 @@ void ContainerSizeEmptyCheck::check(cons
if (Value > 1)
return;
+ if (Value == 1 && (OpCode == BinaryOperatorKind::BO_EQ ||
+ OpCode == BinaryOperatorKind::BO_NE))
+ return;
+
// Always true, no warnings for that.
if ((OpCode == BinaryOperatorKind::BO_GE && Value == 0 && ContainerIsLHS) ||
(OpCode == BinaryOperatorKind::BO_LE && Value == 0 && !ContainerIsLHS))
Modified: clang-tools-extra/trunk/test/clang-tidy/readability-container-size-empty.cpp
URL: http://llvm.org/viewvc/llvm-project/clang-tools-extra/trunk/test/clang-tidy/readability-container-size-empty.cpp?rev=266734&r1=266733&r2=266734&view=diff
==============================================================================
--- clang-tools-extra/trunk/test/clang-tidy/readability-container-size-empty.cpp (original)
+++ clang-tools-extra/trunk/test/clang-tidy/readability-container-size-empty.cpp Tue Apr 19 08:29:05 2016
@@ -7,6 +7,15 @@ template <typename T> struct vector {
bool empty() const;
};
+template <typename T> struct basic_string {
+ basic_string();
+ unsigned long size() const;
+ bool empty() const;
+};
+
+typedef basic_string<char> string;
+typedef basic_string<wchar_t> wstring;
+
inline namespace __v2 {
template <typename T> struct set {
set();
@@ -20,10 +29,24 @@ template <typename T> struct set {
int main() {
std::set<int> intSet;
+ std::string str;
+ std::wstring wstr;
+ str.size() + 0;
+ str.size() - 0;
+ 0 + str.size();
+ 0 - str.size();
if (intSet.size() == 0)
;
// CHECK-MESSAGES: :[[@LINE-2]]:7: warning: the 'empty' method should be used to check for emptiness instead of 'size' [readability-container-size-empty]
// CHECK-FIXES: {{^ }}if (intSet.empty()){{$}}
+ if (str.size() == 0)
+ ;
+ // CHECK-MESSAGES: :[[@LINE-2]]:7: warning: the 'empty' method should be used
+ // CHECK-FIXES: {{^ }}if (str.empty()){{$}}
+ if (wstr.size() == 0)
+ ;
+ // CHECK-MESSAGES: :[[@LINE-2]]:7: warning: the 'empty' method should be used
+ // CHECK-FIXES: {{^ }}if (wstr.empty()){{$}}
std::vector<int> vect;
if (vect.size() == 0)
;
More information about the cfe-commits
mailing list