[PATCH] D11797: [LIbClang] Report the named type for ElaboratedType
Kevin Funk via cfe-commits
cfe-commits at lists.llvm.org
Thu Mar 10 10:01:35 PST 2016
kfunk added inline comments.
================
Comment at: tools/libclang/CXType.cpp:990
@@ -987,1 +989,3 @@
+CXType clang_getNamedTypeUnderlyingElaboratedType(CXType CT){
+ QualType T = GetQualType(CT);
----------------
I'm not happy with this name either. If you look through the libclang API, functions are named like `clang_get${CPPCLASSNAME}${CPPMETHOD}`. E.g. `clang_getEnumConstantDeclValue`, `clang_getFieldDeclBitWidth`, `clang_getFunctionTypeCallingConv`.
Sergey's initial version was closer to that. Maybe `clang_getElaboratedTypeNamedType` will just do...?
http://reviews.llvm.org/D11797
More information about the cfe-commits
mailing list