[PATCH] D16044: getVariableName() for MemRegion
Gábor Horváth via cfe-commits
cfe-commits at lists.llvm.org
Wed Feb 24 08:39:09 PST 2016
xazax.hun added inline comments.
================
Comment at: lib/StaticAnalyzer/Core/MemRegion.cpp:636
@@ +635,3 @@
+std::string MemRegion::getVariableName() const {
+ std::string VariableName{""};
+ std::string ArrayIndices{""};
----------------
Small nit, I prefer to call the default constructor here.
================
Comment at: lib/StaticAnalyzer/Core/MemRegion.cpp:638
@@ +637,3 @@
+ std::string ArrayIndices{""};
+ const clang::ento::MemRegion *R = this;
+ llvm::SmallString<50> buf;
----------------
Small nit: the mentioning the namespaces explicitly here and for smallstring and at some other places is redundant.
http://reviews.llvm.org/D16044
More information about the cfe-commits
mailing list