[PATCH] D16873: Refactor MemRegionManager::getVarRegion to call two new functions, improving readability

Alexander Riccio via cfe-commits cfe-commits at lists.llvm.org
Mon Feb 8 19:38:10 PST 2016


ariccio marked 2 inline comments as done.
ariccio added a comment.

I've reformatted, and changed the `PointerUnion` to a `const StackFrameContext*`.

Built successfully, etc...

(I hope I don't sound too pushy!)


================
Comment at: llvm/tools/clang/lib/StaticAnalyzer/Core/MemRegion.cpp:792
@@ +791,3 @@
+
+const MemRegion*
+MemRegionManager::getMemSpaceForLocalVariable(const VarDecl *D,
----------------
I'm sorry, I think you're right, but I wanna get this patch over with, so I can move on to other things. Some other time, maybe?


http://reviews.llvm.org/D16873





More information about the cfe-commits mailing list