[PATCH] D16873: Refactor MemRegionManager::getVarRegion to call two new functions, improving readability
Alexander Riccio via cfe-commits
cfe-commits at lists.llvm.org
Wed Feb 3 17:56:15 PST 2016
ariccio created this revision.
ariccio added reviewers: aaron.ballman, dcoughlin.
ariccio added a subscriber: cfe-commits.
Instead of one long function, `MemRegionManager::getVarRegion` now calls `getMemRegionGloballyStored` for global, non-static variables, and `getMemRegionStaticLocal` for static locals. The behavior of `MemRegionManager::getVarRegion` is thus clearer, and easier to reason about.
http://reviews.llvm.org/D16873
Files:
llvm/tools/clang/include/clang/StaticAnalyzer/Core/PathSensitive/MemRegion.h
llvm/tools/clang/lib/StaticAnalyzer/Core/MemRegion.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D16873.46848.patch
Type: text/x-patch
Size: 8229 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20160204/b4b4f6fe/attachment-0001.bin>
More information about the cfe-commits
mailing list