[PATCH] D11815: Pass subtarget feature "force-align-stack"
Eric Christopher via cfe-commits
cfe-commits at lists.llvm.org
Thu Aug 27 17:13:15 PDT 2015
echristo added inline comments.
================
Comment at: lib/Driver/Tools.cpp:4232
@@ +4231,3 @@
+ false))
+ CmdArgs.push_back(Args.MakeArgString("-force-align-stack"));
+
----------------
hfinkel wrote:
> The code below for OPT_mstackrealign uses -mstackrealign as the name of the backend option too. Why not do the same for OPT_mstackrealign (use -mstackrealign as the name of the backend option) instead of inventing a new flag name -force-align-stack?
In general we don't do that. But I also don't want this to use a backend option anyhow, why are we doing that here once we have the attribute?
http://reviews.llvm.org/D11815
More information about the cfe-commits
mailing list