[PATCH] D10933: Add new IdentifierNaming check
Beren Minor via cfe-commits
cfe-commits at lists.llvm.org
Thu Aug 6 07:45:44 PDT 2015
berenm marked 24 inline comments as done.
================
Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:513
@@ +512,3 @@
+ }
+
+ if (const auto *Decl = Result.Nodes.getNodeAs<NamedDecl>("decl")) {
----------------
I replaced with StringRef everywhere it looked sensible and the functions return a `std::string`, as they are constructing a new string when computing the fixup.
================
Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:575
@@ +574,2 @@
+} // namespace tidy
+} // namespace clang
----------------
`DeclRange` is actually the `SourceRange` and not the `DeclarationNameInfo`
http://reviews.llvm.org/D10933
More information about the cfe-commits
mailing list