[PATCH] code refactoring on ARMTargetInfo class

Renato Golin renato.golin at linaro.org
Wed Jul 1 03:23:10 PDT 2015


REPOSITORY
  rL LLVM

================
Comment at: lib/Basic/Targets.cpp:4489
@@ +4488,3 @@
+                       (ArchVersion == 5 && CPUAttr.count('E')));
+    bool is32Bit = (!IsThumb || supportsThumb2(CPUAttr));
+    if (is5EOrAbove && is32Bit && (CPUProfile != "M" || CPUAttr  == "7EM"))
----------------
labrinea wrote:
> rengolin wrote:
> > This variable name is odd...
> Are you referring to "is32Bit"? Any suggestions?
Yes. I'm not sure what this is trying to achieve, TBH, but getting "all 32-bit ARM architectures" is not. :)

Though, since this was there before, I guess it's ok to keep it for now. Feel free to add a FIXME comment.

http://reviews.llvm.org/D10839

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the cfe-commits mailing list