[PATCH] refactoring conditions, use isOneOf
Daniel Marjamäki
daniel.marjamaki at evidente.se
Thu Jun 18 01:37:24 PDT 2015
Hi alexfh,
This patch refactors conditions to use isOneOf() instead of multiple is(). It's meant to improve readability. The intention is that this will not affect the behaviour in any way.
http://reviews.llvm.org/D10532
Files:
lib/Format/TokenAnnotator.cpp
lib/Lex/PPDirectives.cpp
lib/Lex/PPMacroExpansion.cpp
lib/Lex/TokenConcatenation.cpp
lib/Lex/TokenLexer.cpp
lib/Parse/ParseCXXInlineMethods.cpp
lib/Parse/ParseDecl.cpp
lib/Parse/ParseDeclCXX.cpp
lib/Parse/ParseExpr.cpp
lib/Parse/ParseExprCXX.cpp
lib/Parse/ParseObjc.cpp
lib/Parse/ParseStmt.cpp
lib/Parse/ParseTemplate.cpp
lib/Parse/ParseTentative.cpp
lib/Sema/SemaDecl.cpp
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D10532.27921.patch
Type: text/x-patch
Size: 49013 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20150618/ba3fe635/attachment.bin>
More information about the cfe-commits
mailing list