[PATCH] Refactor: Move remove-cstr-calls from a standalone executable to a clang-tidy check readability-redundant-string-cstr
Richard
legalize at xmission.com
Sun Mar 15 13:04:01 PDT 2015
Prefer `bind()` over `id()`
Change types to be more consistent with llvm/clang
Chang header guard to be more consistent with llvm/clang
http://reviews.llvm.org/D7318
Files:
CMakeLists.txt
clang-tidy/readability/CMakeLists.txt
clang-tidy/readability/ReadabilityTidyModule.cpp
clang-tidy/readability/RedundantStringCStrCheck.cpp
clang-tidy/readability/RedundantStringCStrCheck.h
remove-cstr-calls/CMakeLists.txt
remove-cstr-calls/Makefile
remove-cstr-calls/RemoveCStrCalls.cpp
test/CMakeLists.txt
test/clang-tidy/readability-redundant-string-cstr.cpp
test/remove-cstr-calls/basic.cpp
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D7318.22000.patch
Type: text/x-patch
Size: 23136 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20150315/41d15245/attachment.bin>
More information about the cfe-commits
mailing list