[PATCH] [Clang Tidy]: Minor cleanups in readability-container-size-empty checker
Gábor Horváth
xazax.hun at gmail.com
Wed Jan 21 03:45:40 PST 2015
Hi alexfh,
Minor cleanups in readability-container-size-empty checker:
- Removed an unused header
- Simplified the custom ast_matchers
http://reviews.llvm.org/D7088
Files:
clang-tidy/readability/ContainerSizeEmpty.cpp
Index: clang-tidy/readability/ContainerSizeEmpty.cpp
===================================================================
--- clang-tidy/readability/ContainerSizeEmpty.cpp
+++ clang-tidy/readability/ContainerSizeEmpty.cpp
@@ -13,7 +13,6 @@
#include "clang/AST/ASTContext.h"
#include "clang/ASTMatchers/ASTMatchers.h"
-#include "clang/ASTMatchers/ASTMatchersInternal.h"
#include "clang/Lex/Lexer.h"
using namespace clang::ast_matchers;
@@ -46,13 +45,8 @@
namespace clang {
namespace ast_matchers {
-AST_MATCHER_P(QualType, unqualifiedType, internal::Matcher<Type>,
- InnerMatcher) {
- return InnerMatcher.matches(*Node, Finder, Builder);
-}
+AST_MATCHER(QualType, isBoolType) { return Node->isBooleanType(); }
-AST_MATCHER(Type, isBoolType) { return Node.isBooleanType(); }
-
AST_MATCHER(NamedDecl, stlContainer) {
return isContainer(Node.getQualifiedNameAsString());
}
@@ -78,12 +72,11 @@
hasLHS(integerLiteral(equals(1)))))))
.bind("SizeBinaryOp")),
hasParent(implicitCastExpr(
- hasImplicitDestinationType(unqualifiedType(isBoolType())),
+ hasImplicitDestinationType(isBoolType()),
anyOf(
hasParent(unaryOperator(hasOperatorName("!")).bind("NegOnSize")),
anything()))),
- hasParent(
- explicitCastExpr(hasDestinationType(unqualifiedType(isBoolType())))));
+ hasParent(explicitCastExpr(hasDestinationType(isBoolType()))));
Finder->addMatcher(
memberCallExpr(
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D7088.18498.patch
Type: text/x-patch
Size: 1537 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20150121/f11fb5d5/attachment.bin>
More information about the cfe-commits
mailing list