[PATCH] Rename flag_enum to enum_role
Sean Hunt
scshunt at csclub.uwaterloo.ca
Mon Jan 5 10:09:31 PST 2015
Hi aaron.ballman,
Per discussions with dgregor, rename the flag_enum attribute to enum_role, and make it more extensible by accepting an argument. I've also made the test coverage a bit more comprehensive.
http://reviews.llvm.org/D6847
Files:
include/clang/Basic/Attr.td
include/clang/Basic/AttrDocs.td
include/clang/Sema/Sema.h
lib/Sema/SemaDecl.cpp
lib/Sema/SemaDeclAttr.cpp
lib/Sema/SemaStmt.cpp
test/Sema/attr-enum-role.c
test/Sema/attr-flag-enum.c
test/SemaCXX/attr-enum-role.cpp
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D6847.17808.patch
Type: text/x-patch
Size: 18347 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20150105/b526931d/attachment.bin>
More information about the cfe-commits
mailing list