[PATCH] [analyzer][Bugfix/improvement] Fix for PR16833
Jordan Rose
jordan_rose at apple.com
Thu Oct 16 09:32:27 PDT 2014
Oh, that's a nice way to refactor RangeConstraintManager::assumeSymLT. Now I'm wondering if it makes sense to do the same for RangeConstraintManager::assumeSymInBound. What do you think?
I discussed this offline with Anna and Ted and one other thing that came up was that this is very specifically operating on //inclusive// bounds. Now, the feature is motivated by the GNU switch extension, so it makes sense to do that, but then it also makes sense to make sure that's very clear for anyone who might want to use the same interface for something else in the future. How about naming it as such?
ProgramState::assumeWithinInclusiveRange
SimpleConstraintManager::assumeSymbolWithinInclusiveRange
RangeConstraintManager::assumeSymbolOutOfInclusiveRange
etc.
http://reviews.llvm.org/D5102
More information about the cfe-commits
mailing list