[PATCH] [OPENMP] Codegen for threadprivate variables
John McCall
rjmccall at gmail.com
Thu Oct 9 15:45:21 PDT 2014
================
Comment at: lib/CodeGen/CGOpenMPRuntime.cpp:364
@@ +363,3 @@
+ /*isVarArg*/ false)->getPointerTo();
+ CCtor = llvm::Constant::getNullValue(CCtorTy);
+ if (Ctor == nullptr) {
----------------
As elsewhere, please rename CCtor to be more easily distinguishable from Ctor.
Please also document what the purpose of this function is and why it's okay to always pass null here.
http://reviews.llvm.org/D4002
More information about the cfe-commits
mailing list