[PATCH] Rename DynTypedNode to ASTNode
Sean Silva
chisophugis at gmail.com
Tue May 20 10:42:29 PDT 2014
On Tue, May 20, 2014 at 11:37 AM, Alp Toker <alp at nuanti.com> wrote:
>
> On 20/05/2014 20:34, Manuel Klimek wrote:
>
> On Tue, May 20, 2014 at 7:19 PM, Sean Silva <chisophugis at gmail.com<mailto:
>> chisophugis at gmail.com>> wrote:
>>
>> Manuel, do you remember why this name was chosen? I seem to recall
>> thinking that the name was well-chosen.
>>
>>
>> It's a DynTypedNode, because the type information is kept / available
>> dynamically. ASTNode would suggest that there is a common interface for AST
>> nodes, which there is not.
>>
>
> Well, QualType is a wrapper around Type structures that works similarly
> and we don't make the distinction there.
>
>
> What doesn't work for me is saying "DynTypedNode is an AST node". This
>> feels wrong. DynTypedNode is more like a "smart reference".
>>
>
> How about ASTNodeRef? I don't have a strong feeling about ASTNode /
> ASTNodeRef or something along those lines, but DynTypedNode specifically
> doesn't feel right.
>
> The current name doesn't mean much outside ASTMatchers lingo whereas the
> functionality is fairly general and could be useful elsewhere.
>
There was some speculation about extending use of DynTypedNode outside the
ASTMatchers library http://reviews.llvm.org/D33?id=85#inline-386; is there
something in particular that you have in mind that you are trying to work
towards?
-- Sean Silva
>
> Alp.
>
>
>
>
>> Cheers,
>> /Manuel
>>
>>
>> -- Sean Silva
>>
>>
>> On Sun, May 18, 2014 at 11:18 PM, Alp Toker <alp at nuanti.com
>> <mailto:alp at nuanti.com>> wrote:
>>
>> This is always referred to as an AST node in documentation. By
>> wrapping Decls, Stmts and QualTypes it provides a generalised
>> way to reference AST nodes. And despite the name, DynTypedNode
>> doesn't have anything to do with dynamic types in the AST.
>>
>> The attached patch renames the class and implementation to
>> ASTNode.
>>
>> (Indeed the namespace "ast_type_traits" is equally confusing.
>> Presumably both are cases where implementation details have
>> leaked into the naming scheme?)
>>
>> Alp.
>>
>> -- http://www.nuanti.com
>> the browser experts
>>
>>
>> _______________________________________________
>> cfe-commits mailing list
>> cfe-commits at cs.uiuc.edu <mailto:cfe-commits at cs.uiuc.edu>
>> http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits
>>
>>
>>
>>
> --
> http://www.nuanti.com
> the browser experts
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20140520/b6fc09e4/attachment.html>
More information about the cfe-commits
mailing list