[PATCH] Add new 'let' command to bind arbitrary values into constants.
Peter Collingbourne
peter at pcc.me.uk
Thu Apr 17 12:01:56 PDT 2014
================
Comment at: clang-query/QueryParser.cpp:270
@@ +269,3 @@
+
+ return new LetQuery(Name, {});
+ }
----------------
Can you please use 'endQuery' here so that extra input causes an error?
================
Comment at: clang-query/Query.h:34
@@ -34,1 +33,3 @@
+ QK_SetOutputKind,
+ QK_Let,
};
----------------
Sorry, missed this one -- alphabetical order, please.
================
Comment at: clang-query/QueryParser.cpp:264
@@ -216,1 +263,3 @@
+ case PQK_Unlet: {
+ StringRef Name = lexWord();
----------------
It would be nice to support completion for value names here.
================
Comment at: clang-query/QueryParser.cpp:71
@@ -70,3 +70,3 @@
Switch.Case(S, Value);
else if (N != 1 && IsCompletion && WordCompletionPos <= CaseStr.size() &&
CaseStr.substr(0, WordCompletionPos) ==
----------------
You could factor this code out into a completeWord function.
http://reviews.llvm.org/D3383
More information about the cfe-commits
mailing list