[PATCH] Fix PR19408 -- Missing static this adjustment in a vtordisp thunk

Reid Kleckner rnk at google.com
Wed Apr 16 09:53:39 PDT 2014


  lgtm


================
Comment at: lib/AST/VTableBuilder.cpp:2749
@@ +2748,3 @@
+    TA.NonVirtual = (OverriderRDLayout.getVBaseClassOffset(ML.VBase) +
+                     ML.VFPtrOffset - ThisOffset).getQuantity();
+    return;
----------------
I never know what 'ThisOffset' refers to in this code.  Is there a better name we could use?


http://reviews.llvm.org/D3400






More information about the cfe-commits mailing list