[PATCH] [analyzer][Review request] Improved checker naming in CFG dump.
Ted Kremenek
kremenek at apple.com
Fri Feb 14 20:14:16 PST 2014
Overall, looks good to me.
================
Comment at: include/clang/StaticAnalyzer/Core/Checker.h:471
@@ +470,3 @@
+
+// Tag that uses checker name as a message provider (see SimpleProgramPointTag).
+class CheckerProgramPointTag : public SimpleProgramPointTag {
----------------
Please make this a doxygen comment.
================
Comment at: lib/StaticAnalyzer/Core/ExprEngine.cpp:1276
@@ -1275,3 +1275,3 @@
if (nodeBuilder.getContext().blockCount() >= AMgr.options.maxBlockVisitOnPath) {
- static SimpleProgramPointTag tag("ExprEngine : Block count exceeded");
+ static SimpleProgramPointTag tag("ExprEngine", "Block count exceeded");
const ExplodedNode *Sink =
----------------
It would be great if we didn't write the string constant "ExprEngine" several times. If we ever change it we need to update it in several places, but that was a sin we already committed before this patch (so it can be addressed later).
http://llvm-reviews.chandlerc.com/D2793
More information about the cfe-commits
mailing list