r190268 - Debug Info: pass in DIScope instead of DIDescriptor in createFieldType.
Manman Ren
manman.ren at gmail.com
Sat Sep 7 20:45:06 PDT 2013
Author: mren
Date: Sat Sep 7 22:45:05 2013
New Revision: 190268
URL: http://llvm.org/viewvc/llvm-project?rev=190268&view=rev
Log:
Debug Info: pass in DIScope instead of DIDescriptor in createFieldType.
Improve readability. No functionality change.
Modified:
cfe/trunk/lib/CodeGen/CGDebugInfo.cpp
cfe/trunk/lib/CodeGen/CGDebugInfo.h
Modified: cfe/trunk/lib/CodeGen/CGDebugInfo.cpp
URL: http://llvm.org/viewvc/llvm-project/cfe/trunk/lib/CodeGen/CGDebugInfo.cpp?rev=190268&r1=190267&r2=190268&view=diff
==============================================================================
--- cfe/trunk/lib/CodeGen/CGDebugInfo.cpp (original)
+++ cfe/trunk/lib/CodeGen/CGDebugInfo.cpp Sat Sep 7 22:45:05 2013
@@ -788,7 +788,7 @@ llvm::DIType CGDebugInfo::createFieldTyp
AccessSpecifier AS,
uint64_t offsetInBits,
llvm::DIFile tunit,
- llvm::DIDescriptor scope) {
+ llvm::DIScope scope) {
llvm::DIType debugType = getOrCreateType(type, tunit);
// Get the location for the field.
Modified: cfe/trunk/lib/CodeGen/CGDebugInfo.h
URL: http://llvm.org/viewvc/llvm-project/cfe/trunk/lib/CodeGen/CGDebugInfo.h?rev=190268&r1=190267&r2=190268&view=diff
==============================================================================
--- cfe/trunk/lib/CodeGen/CGDebugInfo.h (original)
+++ cfe/trunk/lib/CodeGen/CGDebugInfo.h Sat Sep 7 22:45:05 2013
@@ -179,7 +179,7 @@ class CGDebugInfo {
uint64_t sizeInBitsOverride, SourceLocation loc,
AccessSpecifier AS, uint64_t offsetInBits,
llvm::DIFile tunit,
- llvm::DIDescriptor scope);
+ llvm::DIScope scope);
// Helpers for collecting fields of a record.
void CollectRecordLambdaFields(const CXXRecordDecl *CXXDecl,
More information about the cfe-commits
mailing list