[PATCH] Refactor VariantMatcher to use an interface underneath.
Samuel Benzaquen
sbenza at google.com
Thu Aug 22 07:06:48 PDT 2013
================
Comment at: include/clang/ASTMatchers/Dynamic/VariantValue.h:56
@@ +55,3 @@
+ ///
+ /// It follows a similar interface than VariantMatcher itself.
+ class Payload {
----------------
Manuel Klimek wrote:
> isn't it similar ... as?
Done.
================
Comment at: include/clang/ASTMatchers/Dynamic/VariantValue.h:57
@@ +56,3 @@
+ /// It follows a similar interface than VariantMatcher itself.
+ class Payload {
+ public:
----------------
Manuel Klimek wrote:
> It looks like Payload basically carries around the type information. Thus, I'd call it TypeInfo?
Well, it carries the type information, plus the actual value.
http://llvm-reviews.chandlerc.com/D1446
BRANCH
variant_matcher
ARCANIST PROJECT
clang
More information about the cfe-commits
mailing list