[PATCH] cpp11-migrate: Add a class to support include directives modifications
Guillaume Papin
guillaume.papin at epitech.eu
Thu Aug 15 13:17:01 PDT 2013
Thanks for the review.
> I would remove mention of what you call X Macro Headers and just say "headers meant for multiple inclusion".
Done.
================
Comment at: cpp11-migrate/Core/IncludeDirectives.h:44
@@ +43,3 @@
+ ///
+ /// \return A replacement that is either null if the include already visible
+ /// by file (check with \c Replacement::isApplicable()) or non-null
----------------
Edwin Vane wrote:
> I'd reword this for clarity this way:
>
> \returns \li A null Replacement (check using \c Replacement::isApplicable()), if the \c Include is already visible from \c File.
> \li Otherwise, a non-null Replacement that, when applied, inserts an \c #include into \c File.
Done!
================
Comment at: cpp11-migrate/Core/IncludeDirectives.h:52
@@ +51,3 @@
+
+ /// \brief Check if \p Include is included by \p File or any of the file \p
+ /// File includes.
----------------
Edwin Vane wrote:
> file -> files
Fixed.
http://llvm-reviews.chandlerc.com/D1287
BRANCH
include-directives
ARCANIST PROJECT
clang-tools-extra
More information about the cfe-commits
mailing list