[PATCH] cpp11-migrate: Further generalize replacements serialization
Tareq A. Siraj
tareq.a.siraj at intel.com
Thu Aug 15 10:57:35 PDT 2013
Minor comments, otherwise LGTM.
================
Comment at: cpp11-migrate/Core/FileOverrides.h:74
@@ -74,2 +73,3 @@
/// \brief Getter for FileName.
llvm::StringRef getFileName() const {
+ return HeaderPath;
----------------
We should also rename this function to be more specific about which filename its returning.
================
Comment at: cpp11-migrate/Core/ReplacementsYaml.h:95
@@ +94,3 @@
+struct MappingTraits<ReplacementsDocument> {
+ static void mapping(IO &Io, ReplacementsDocument &TD) {
+ Io.mapOptional("Context", TD.Context, std::string());
----------------
The var name for ReplacementsDocument should probably be renamed to "Doc".
http://llvm-reviews.chandlerc.com/D1413
More information about the cfe-commits
mailing list