[PATCH] Macro and conditional checking feature addition to the modularize tool
Sean Silva
silvas at purdue.edu
Wed Jul 24 20:03:51 PDT 2013
Hey Doug, could you take a look at this?
-- Sean Silva
On Fri, Jul 19, 2013 at 5:18 PM, Thompson, John <
John_Thompson at playstation.sony.com> wrote:
> Sean,****
>
> ** **
>
> Thanks for looking at this. I’ve enclosed a revised patch.****
>
> ** **
>
> Sorry, it didn’t sink in that all variable names need to start with
> uppercase, not just parameters and members, reinforced by seeing violations
> in other clang code. I’ve tried to fix all these and a couple other
> violations I could find, but I might still need some hand-holding.****
>
> ** **
>
> Perhaps clang-format could check naming, or there could be a tool for
> checking all conventions?****
>
> ** **
>
> -John****
>
> ** **
>
> *From:* Sean Silva [mailto:silvas at purdue.edu]
> *Sent:* Friday, July 19, 2013 4:20 PM
> *To:* Thompson, John
> *Cc:* cfe-commits at cs.uiuc.edu
> *Subject:* Re: [PATCH] Macro and conditional checking feature addition to
> the modularize tool****
>
> ** **
>
> + clang::SourceLocation bLoc(Range.getBegin());****
>
> + const char *bPtr = PP.getSourceManager().getCharacterData(bLoc);****
>
> + size_t length;****
>
> ** **
>
> Please follow the naming conventions set forth in <
> http://llvm.org/docs/CodingStandards.html>. This seems to be a recurring
> issue; please take the necessary steps to ensure future patches comply with
> LLVM coding standards.****
>
> ** **
>
> -- Sean Silva****
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20130724/0f651a09/attachment.html>
More information about the cfe-commits
mailing list