[PATCH] Macro and conditional checking feature addition to the modularize tool

Thompson, John John_Thompson at playstation.sony.com
Fri Jul 19 17:18:10 PDT 2013


Sean,

Thanks for looking at this.  I've enclosed a revised patch.

Sorry, it didn't sink in that all variable names need to start with uppercase, not just parameters and members, reinforced by seeing violations in other clang code.  I've tried to fix all these and a couple other violations I could find, but I might still need some hand-holding.

Perhaps clang-format could check naming, or there could be a tool for checking all conventions?

-John

From: Sean Silva [mailto:silvas at purdue.edu]
Sent: Friday, July 19, 2013 4:20 PM
To: Thompson, John
Cc: cfe-commits at cs.uiuc.edu
Subject: Re: [PATCH] Macro and conditional checking feature addition to the modularize tool

+  clang::SourceLocation bLoc(Range.getBegin());
+  const char *bPtr = PP.getSourceManager().getCharacterData(bLoc);
+  size_t length;

Please follow the naming conventions set forth in <http://llvm.org/docs/CodingStandards.html>. This seems to be a recurring issue; please take the necessary steps to ensure future patches comply with LLVM coding standards.

-- Sean Silva
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20130720/f86a4ff8/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: mod_2013_07_19_patch_2.txt
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20130720/f86a4ff8/attachment.txt>


More information about the cfe-commits mailing list