ObjFW runtime: Add objc_msg_lookup(_super)_{fp,st}ret
Jonathan Schleifer
js at webkeks.org
Thu Jul 11 15:13:08 PDT 2013
Am 11.07.2013 um 03:46 schrieb Eli Friedman:
> It's returned in a different kind of temporary, so the ABI code
> doesn't consider it "stret".
But it's not passed as an argument before all other arguments, like with stret, thus not going to crash when the normal forwarding routine is used?
> Missing documentation patch for the __has_feature. Also, not sure I
> like the name; can you try for something more descriptive?
I can't really think of a more descriptive name :/. IMHO, it is pretty descriptive:
* objc_ tells you it's an objc feature
* msg_lookup tells you it's message lookup related
* stret tells you it supports struct return
* together it tells you that objc supports lookup for struct return
Do you have suggestions for something better?
> You can combine the two tests into one using FileCheck's -check-prefix flag.
I tried that, but it doesn't work. The second test fails to even recognize something as simple as define void @test0(). Can you please have a look at the attached test?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: stret_lookup.m
Type: application/octet-stream
Size: 1246 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20130712/87a67b7a/attachment.obj>
-------------- next part --------------
--
Jonathan
More information about the cfe-commits
mailing list