[cfe-commits] [PATCH] Oz optimization level sets ForceSizeOpt attribute for each function

Quentin Colombet qcolombet at apple.com
Mon Oct 29 14:36:10 PDT 2012

On Oct 29, 2012, at 2:27 PM, Chandler Carruth <chandlerc at google.com> wrote:

> On Mon, Oct 29, 2012 at 2:23 PM, Eric Christopher <echristo at gmail.com> wrote:
>>> There is no disagreement on coming up with a good name. I just don't think we should tackle the "optimize-for-size-level" part. Ideally it's one attribute with rather than multiple attributes. i.e.
>>> optsize=1
>>> optsize=2
>>> optsize=3
>>> Rather than
>>> optsize
>>> optsizeharder
>>> optsizereallyhard
>>> The former will require significant changes and it is not something we'd want Quentin to tackle at this time.
>>> For the record, -Os / -Oz do not have exact definitions. They are (intentionally?) subject to interpretation by different compilers / targets.
>> This is why I hate -Oz :)
>> As a range of values it could work, but let's just pick some better
>> names for now, how about a quick straw poll:
>> OptSize/ForceOptSize -> OptSize/MinSize
> +1

Works for me too!

I will change the name and propose a patch for that.
I will do the same for the attribute I proposed in my last patch.


More information about the cfe-commits mailing list