[cfe-commits] [PATCH] Macro history (de-)serialization.
Richard Smith
reviews at llvm-reviews.chandlerc.com
Thu Sep 13 11:14:55 PDT 2012
================
Comment at: tools/clang/include/clang/Lex/Preprocessor.h:474
@@ +473,3 @@
+ /// identifiers that hadMacroDefinition().
+ MacroInfo *getInfoForMacro(IdentifierInfo *II) const;
+
----------------
If we're going to expose this, I think it should be renamed to avoid confusion with "getMacroInfo". How about "getMacroInfoHistory"?
================
Comment at: tools/clang/lib/Serialization/ASTReader.cpp:541-542
@@ -540,4 +543,2 @@
Bits >>= 1;
- unsigned ObjCOrBuiltinID = Bits & 0x7FF;
- Bits >>= 11;
----------------
Do we actually use all 11 bits of ObjCOrBuiltinID? If we can just shrink it to 10 bits, that would seem preferable.
http://llvm-reviews.chandlerc.com/D41
More information about the cfe-commits
mailing list