[cfe-commits] [PATCH] Fix name clash (Name clash causing troubles)

Jordan Rose jordan_rose at apple.com
Tue Jul 3 16:25:43 PDT 2012

>>> I think it's just so it will never intersect with a valid value. If these constants are exposed in libclang, they're expected to remain stable. Then again, CK_Invalid probably may not be exposed in libclang even if the others are.
>>> I agree with Enea that it's probably not in the enum so that exhaustive switch statements can ignore it -- you should never actually be consuming a cast with CK_Invalid type. And in general I think I agree that we should try to have a different prefix for comment kinds: RC_ or RCK_, since both comment kinds and cast kinds /could/ show up in the same section of code.
>> I've attached a patch to do that. If you don't have any objection I'll
>> apply it.
> Renaming RawCommentList enum members LGTM.

Me too; thanks, Abramo.

More information about the cfe-commits mailing list