[cfe-commits] [patch] Rename -Wself-assign-memvar to -Wself-assign-field

Jordan Rose jordan_rose at apple.com
Mon Jul 2 17:47:20 PDT 2012

On Jul 2, 2012, at 5:40 PM, Chandler Carruth wrote:

> I'd be very happy for the diagnostic text to use more specialized terminology when it can -- I think that makes the user experience quite a bit better.
> Not sure its worth having two flags though.

I already made Nico do that :-) and yes, I agree about the flags. I just wanted to make sure we didn't end up with something exclusively C++. ("field", of course, is just falling back to the common denominator of C.)

More information about the cfe-commits mailing list