[cfe-commits] r138992 - /cfe/trunk/lib/Sema/SemaExpr.cpp

Sebastian Redl sebastian.redl at getdesigned.at
Fri Sep 2 04:35:06 PDT 2011

On 02.09.2011 03:51, Richard Trieu wrote:
> Author: rtrieu
> Date: Thu Sep  1 20:51:02 2011
> New Revision: 138992
> URL: http://llvm.org/viewvc/llvm-project?rev=138992&view=rev
> Log:
> Refactor CheckConditionalOperands() by moving chunks of code to helper functions making a slimmer function.
I don't like the naming convention of these helpers. I'd prefer them to 
begin with 'try' and follow a similar pattern as the functions in the 
named cast handling. (CheckStaticCast, I think.) This is just my 
opinion, though.


More information about the cfe-commits mailing list