[cfe-commits] r130672 - /cfe/trunk/lib/CodeGen/CGObjCGNU.cpp
Nick Lewycky
nicholas at mxc.ca
Sun May 1 17:40:24 PDT 2011
Author: nicholas
Date: Sun May 1 19:40:24 2011
New Revision: 130672
URL: http://llvm.org/viewvc/llvm-project?rev=130672&view=rev
Log:
Remove a dead variable flagged by gcc's -Wunused-but-set-variable. No
functionality change.
Modified:
cfe/trunk/lib/CodeGen/CGObjCGNU.cpp
Modified: cfe/trunk/lib/CodeGen/CGObjCGNU.cpp
URL: http://llvm.org/viewvc/llvm-project/cfe/trunk/lib/CodeGen/CGObjCGNU.cpp?rev=130672&r1=130671&r2=130672&view=diff
==============================================================================
--- cfe/trunk/lib/CodeGen/CGObjCGNU.cpp (original)
+++ cfe/trunk/lib/CodeGen/CGObjCGNU.cpp Sun May 1 19:40:24 2011
@@ -2005,12 +2005,10 @@
const llvm::StructType *SelStructTy = dyn_cast<llvm::StructType>(
SelectorTy->getElementType());
const llvm::Type *SelStructPtrTy = SelectorTy;
- bool isSelOpaque = false;
if (SelStructTy == 0) {
SelStructTy = llvm::StructType::get(VMContext, PtrToInt8Ty,
PtrToInt8Ty, NULL);
SelStructPtrTy = llvm::PointerType::getUnqual(SelStructTy);
- isSelOpaque = true;
}
// Name the ObjC types to make the IR a bit easier to read
More information about the cfe-commits
mailing list