[cfe-commits] Patch to remove some code duplication
clattner at apple.com
Fri Aug 29 09:44:04 PDT 2008
On Aug 29, 2008, at 1:45 AM, Nico Weber wrote:
> this removes some code duplication. The function
> DefineBuiltinMacro() is useful for other clients, too.
I'm not sure this patch is a good idea. The Preprocessor interface is
already really complex, and this method doesn't use the preprocessor
at all: it is just a helper method for injecting a string into a
vector. At the least, it should be a static method, but could it be
moved somewhere else?
More information about the cfe-commits