[all-commits] [llvm/llvm-project] 87e45f: [SBVec] Rename BottomUpVec to BundleVec

Anshil Gandhi via All-commits all-commits at lists.llvm.org
Sun Aug 2 21:33:48 PDT 2026


  Branch: refs/heads/users/gandhi56/sandbox-vectorizer/rename-bottom-up-vec
  Home:   https://github.com/llvm/llvm-project
  Commit: 87e45f4ad4f655591ce85250f713cf0ba64b2e4a
      https://github.com/llvm/llvm-project/commit/87e45f4ad4f655591ce85250f713cf0ba64b2e4a
  Author: Anshil Gandhi <gandhi21299 at gmail.com>
  Date:   2026-08-03 (Mon, 03 Aug 2026)

  Changed paths:
    M llvm/docs/SandboxVectorizer.md
    R llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/BottomUpVec.h
    A llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/BundleVec.h
    M llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/LoadStoreVec.h
    M llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/RegionsFromMetadata.h
    M llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/SeedCollection.h
    M llvm/lib/Transforms/Vectorize/CMakeLists.txt
    R llvm/lib/Transforms/Vectorize/SandboxVectorizer/Passes/BottomUpVec.cpp
    A llvm/lib/Transforms/Vectorize/SandboxVectorizer/Passes/BundleVec.cpp
    M llvm/lib/Transforms/Vectorize/SandboxVectorizer/Passes/PassRegistry.def
    M llvm/lib/Transforms/Vectorize/SandboxVectorizer/SandboxVectorizer.cpp
    M llvm/lib/Transforms/Vectorize/SandboxVectorizer/SandboxVectorizerPassBuilder.cpp
    M llvm/test/Transforms/SandboxVectorizer/allow_files.ll
    R llvm/test/Transforms/SandboxVectorizer/bottomup_basic.ll
    R llvm/test/Transforms/SandboxVectorizer/bottomup_seed_slice.ll
    R llvm/test/Transforms/SandboxVectorizer/bottomup_seed_slice_pow2.ll
    A llvm/test/Transforms/SandboxVectorizer/bundle_basic.ll
    A llvm/test/Transforms/SandboxVectorizer/bundle_seed_slice.ll
    A llvm/test/Transforms/SandboxVectorizer/bundle_seed_slice_pow2.ll
    A llvm/test/Transforms/SandboxVectorizer/bundle_vec_aux_arg.ll
    M llvm/test/Transforms/SandboxVectorizer/cross_bbs.ll
    M llvm/test/Transforms/SandboxVectorizer/default_pass_pipeline.ll
    M llvm/test/Transforms/SandboxVectorizer/external_uses.ll
    M llvm/test/Transforms/SandboxVectorizer/load_store_vec.ll
    M llvm/test/Transforms/SandboxVectorizer/pack.ll
    M llvm/test/Transforms/SandboxVectorizer/pack_reuse_end_to_end.ll
    M llvm/test/Transforms/SandboxVectorizer/repeated_instrs.ll
    M llvm/test/Transforms/SandboxVectorizer/scheduler.ll
    M llvm/test/Transforms/SandboxVectorizer/special_opcodes.ll
    M llvm/test/Transforms/SandboxVectorizer/stop_at.ll
    M llvm/test/Transforms/SandboxVectorizer/stop_bndl.ll
    M llvm/test/Transforms/SandboxVectorizer/topdown_vec.ll
    M llvm/utils/gn/secondary/llvm/lib/Transforms/Vectorize/BUILD.gn

  Log Message:
  -----------
  [SBVec] Rename BottomUpVec to BundleVec



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list