[all-commits] [llvm/llvm-project] 531f8a: [NFC] Rename BottomUpVec to SLPTreeVec

Anshil Gandhi via All-commits all-commits at lists.llvm.org
Thu Jul 30 21:24:08 PDT 2026


  Branch: refs/heads/users/gandhi56/sandbox-vectorizer/rename-bottom-up-vec
  Home:   https://github.com/llvm/llvm-project
  Commit: 531f8af7eb59eec403ea41856a507998f9c88a09
      https://github.com/llvm/llvm-project/commit/531f8af7eb59eec403ea41856a507998f9c88a09
  Author: Anshil Gandhi <gandhi21299 at gmail.com>
  Date:   2026-07-31 (Fri, 31 Jul 2026)

  Changed paths:
    M llvm/docs/SandboxVectorizer.md
    R llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/BottomUpVec.h
    M llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/LoadStoreVec.h
    M llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/RegionsFromMetadata.h
    A llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/SLPTreeVec.h
    M llvm/include/llvm/Transforms/Vectorize/SandboxVectorizer/Passes/SeedCollection.h
    M llvm/lib/Transforms/Vectorize/CMakeLists.txt
    R llvm/lib/Transforms/Vectorize/SandboxVectorizer/Passes/BottomUpVec.cpp
    M llvm/lib/Transforms/Vectorize/SandboxVectorizer/Passes/PassRegistry.def
    A llvm/lib/Transforms/Vectorize/SandboxVectorizer/Passes/SLPTreeVec.cpp
    M llvm/lib/Transforms/Vectorize/SandboxVectorizer/SandboxVectorizer.cpp
    M llvm/lib/Transforms/Vectorize/SandboxVectorizer/SandboxVectorizerPassBuilder.cpp
    M llvm/test/Transforms/SandboxVectorizer/allow_files.ll
    R llvm/test/Transforms/SandboxVectorizer/bottomup_basic.ll
    R llvm/test/Transforms/SandboxVectorizer/bottomup_seed_slice.ll
    R llvm/test/Transforms/SandboxVectorizer/bottomup_seed_slice_pow2.ll
    M llvm/test/Transforms/SandboxVectorizer/cross_bbs.ll
    M llvm/test/Transforms/SandboxVectorizer/default_pass_pipeline.ll
    M llvm/test/Transforms/SandboxVectorizer/external_uses.ll
    M llvm/test/Transforms/SandboxVectorizer/load_store_vec.ll
    M llvm/test/Transforms/SandboxVectorizer/pack.ll
    M llvm/test/Transforms/SandboxVectorizer/pack_reuse_end_to_end.ll
    M llvm/test/Transforms/SandboxVectorizer/repeated_instrs.ll
    M llvm/test/Transforms/SandboxVectorizer/scheduler.ll
    A llvm/test/Transforms/SandboxVectorizer/slp_tree_basic.ll
    A llvm/test/Transforms/SandboxVectorizer/slp_tree_seed_slice.ll
    A llvm/test/Transforms/SandboxVectorizer/slp_tree_seed_slice_pow2.ll
    M llvm/test/Transforms/SandboxVectorizer/special_opcodes.ll
    M llvm/test/Transforms/SandboxVectorizer/stop_at.ll
    M llvm/test/Transforms/SandboxVectorizer/stop_bndl.ll
    M llvm/utils/gn/secondary/llvm/lib/Transforms/Vectorize/BUILD.gn

  Log Message:
  -----------
  [NFC] Rename BottomUpVec to SLPTreeVec



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list