[all-commits] [llvm/llvm-project] 1945b4: [AArch64][PAC] Rework the expansion of AUT/AUTPAC ...

Anatoly Trosinenko via All-commits all-commits at lists.llvm.org
Fri Jul 17 05:46:43 PDT 2026


  Branch: refs/heads/users/atrosinenko/pauth-refactor-autpac
  Home:   https://github.com/llvm/llvm-project
  Commit: 1945b47536970a4c0f5e137f31c29fdce78a184b
      https://github.com/llvm/llvm-project/commit/1945b47536970a4c0f5e137f31c29fdce78a184b
  Author: Anatoly Trosinenko <atrosinenko at accesssoftek.com>
  Date:   2026-07-17 (Fri, 17 Jul 2026)

  Changed paths:
    M llvm/lib/Target/AArch64/AArch64AsmPrinter.cpp
    M llvm/test/CodeGen/AArch64/ptrauth-intrinsic-auth-resign-with-blend.ll

  Log Message:
  -----------
  [AArch64][PAC] Rework the expansion of AUT/AUTPAC pseudos

Refactor `AArch64AsmPrinter::emitPtrauthAuthResign` to improve
readability and fix the conditions when `emitPtrauthDiscriminator` is
allowed to clobber AddrDisc.

* do not clobber `AUTAddrDisc` when computing `AUTDiscReg` on resigning
  if `AUTAddrDisc == PACAddrDisc`, as it would prevent passing raw,
  64-bit value as the new discriminator
* move the code computing `ShouldCheck` and `ShouldTrap` conditions to a
  separate function


  Commit: 4a0d7733c9fdcbf2d80ccb3b7db74f6922a5e65f
      https://github.com/llvm/llvm-project/commit/4a0d7733c9fdcbf2d80ccb3b7db74f6922a5e65f
  Author: Anatoly Trosinenko <atrosinenko at accesssoftek.com>
  Date:   2026-07-17 (Fri, 17 Jul 2026)

  Changed paths:
    M llvm/lib/Target/AArch64/AArch64AsmPrinter.cpp

  Log Message:
  -----------
  Use enum instead of a pair of boolean variables


  Commit: 2c1939595588e407297ce1a5910a1bfb848c58dc
      https://github.com/llvm/llvm-project/commit/2c1939595588e407297ce1a5910a1bfb848c58dc
  Author: Anatoly Trosinenko <atrosinenko at accesssoftek.com>
  Date:   2026-07-17 (Fri, 17 Jul 2026)

  Changed paths:
    M llvm/lib/Target/AArch64/AArch64AsmPrinter.cpp
    M llvm/lib/Target/AArch64/AArch64InstrInfo.td
    M llvm/test/CodeGen/AArch64/ptrauth-intrinsic-auth-resign-with-blend.ll

  Log Message:
  -----------
  Add more test cases; other minor changes


  Commit: b82fdb2ba1c224ba6c7e0db11e9cc532daebb022
      https://github.com/llvm/llvm-project/commit/b82fdb2ba1c224ba6c7e0db11e9cc532daebb022
  Author: Anatoly Trosinenko <atrosinenko at accesssoftek.com>
  Date:   2026-07-17 (Fri, 17 Jul 2026)

  Changed paths:
    M llvm/lib/Target/AArch64/AArch64AsmPrinter.cpp
    M llvm/lib/Target/AArch64/AArch64InstrInfo.td

  Log Message:
  -----------
  Minor comment fixes and s/AuthWithPC/IsAuthWithPC/


Compare: https://github.com/llvm/llvm-project/compare/a7cbe3c421c8...b82fdb2ba1c2

To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list