[all-commits] [llvm/llvm-project] 7881a3: [mlir][linalg] Refine pack/unpack simplification c...

Andrzej Warzyński via All-commits all-commits at lists.llvm.org
Tue Jul 14 23:58:17 PDT 2026


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 7881a375884c3793d2fa7c31ab97781a43547f31
      https://github.com/llvm/llvm-project/commit/7881a375884c3793d2fa7c31ab97781a43547f31
  Author: Andrzej Warzyński <andrzej.warzynski at arm.com>
  Date:   2026-07-15 (Wed, 15 Jul 2026)

  Changed paths:
    M mlir/lib/Dialect/Linalg/Transforms/PackAndUnpackPatterns.cpp
    M mlir/test/Dialect/Linalg/simplify-pack-unpack.mlir

  Log Message:
  -----------
  [mlir][linalg] Refine pack/unpack simplification checks (NFC) (#209522)

Update `isPackOn1D`, which is used by both
`SimplifyPackToExpandShape` and `SimplifyUnPackToCollapseShape`:

* Rename it to `isPackOnEffectively1D` to better reflect its
   functionality: the underlying pack can be multi-dimensional.
* Add checks to ensure that the unique non-unit inner tile is used to
   tile the unique non-unit unpacked dimension (that was previously
   left as an unchecked assumption).
* Add comments to the test file for these patterns, grouping the tests
   according to the functionality/cases being tested.



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list