[all-commits] [llvm/llvm-project] 5d68f7: [Analysis] Improve readability of `KnownBits::pext...

Jan Schultke via All-commits all-commits at lists.llvm.org
Sat Jun 27 04:43:15 PDT 2026


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 5d68f75b53458604b11efb66192840f1cecd8ffa
      https://github.com/llvm/llvm-project/commit/5d68f75b53458604b11efb66192840f1cecd8ffa
  Author: Jan Schultke <me at eisenwave.net>
  Date:   2026-06-27 (Sat, 27 Jun 2026)

  Changed paths:
    M llvm/include/llvm/Support/KnownBits.h
    M llvm/lib/Support/KnownBits.cpp

  Log Message:
  -----------
  [Analysis] Improve readability of `KnownBits::pext` and `KnownBits::pdep` (#205176)

- Change the parameter names to `Val` and `Mask` to emphasize their semantics.
- Use `clearBits` instead of bitwise AND for increased expressiveness.
- Rewrite explanatory comments.



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list