[all-commits] [llvm/llvm-project] 3b63f0: [mlir][vector] extend `createReadOrMaskedRead`/`cr...

Federico Bruzzone via All-commits all-commits at lists.llvm.org
Fri Jun 12 05:48:44 PDT 2026


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 3b63f045b9a994e275d8fd186f2de96939c38378
      https://github.com/llvm/llvm-project/commit/3b63f045b9a994e275d8fd186f2de96939c38378
  Author: Federico Bruzzone <federico.bruzzone.i at gmail.com>
  Date:   2026-06-12 (Fri, 12 Jun 2026)

  Changed paths:
    M mlir/include/mlir/Dialect/Vector/IR/VectorOps.td
    M mlir/include/mlir/Dialect/Vector/Utils/VectorUtils.h
    M mlir/lib/Dialect/Affine/Transforms/SuperVectorize.cpp
    M mlir/lib/Dialect/Vector/IR/VectorOps.cpp
    M mlir/lib/Dialect/Vector/Utils/VectorUtils.cpp

  Log Message:
  -----------
  [mlir][vector] extend `createReadOrMaskedRead`/`createWriteOrMaskedWrite` with permutation map support (#202766)

Follow-up to #201180.

Extends the existing `createReadOrMaskedRead` and
`createWriteOrMaskedWrite` utilities in `VectorUtils` with two optional
trailing parameters:
- `ArrayRef<Value> indices`
- `AffineMap permutationMap`

The affine super-vectorizer is updated to call these functions instead
of constructing `TransferReadOp`/`TransferWriteOp` directly.

@banach-space, please correct me if this wasn't what you meant in the
previous PR.

---------

Signed-off-by: Federico Bruzzone <federico.bruzzone.i at gmail.com>
Co-authored-by: Andrzej WarzyƄski <andrzej.warzynski at gmail.com>



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list