[all-commits] [llvm/llvm-project] f5fed7: [VPlan] Rename VPIRFlags::getFastMathFlags (NFC) (...
Ramkumar Ramachandra via All-commits
all-commits at lists.llvm.org
Mon Jun 8 08:08:39 PDT 2026
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: f5fed78bbe847f7c02fd69c6f33a0f916c8fdadb
https://github.com/llvm/llvm-project/commit/f5fed78bbe847f7c02fd69c6f33a0f916c8fdadb
Author: Ramkumar Ramachandra <artagnon at tenstorrent.com>
Date: 2026-06-08 (Mon, 08 Jun 2026)
Changed paths:
M llvm/lib/Transforms/Vectorize/LoopVectorize.cpp
M llvm/lib/Transforms/Vectorize/VPlan.h
M llvm/lib/Transforms/Vectorize/VPlanConstruction.cpp
M llvm/lib/Transforms/Vectorize/VPlanRecipes.cpp
M llvm/lib/Transforms/Vectorize/VPlanTransforms.cpp
M llvm/lib/Transforms/Vectorize/VPlanUnroll.cpp
Log Message:
-----------
[VPlan] Rename VPIRFlags::getFastMathFlags (NFC) (#200487)
Rename it to getFastMathFlagsOrNone, in line with the recently-landed IR
change 02997d759 ([IR] Introduce Instruction::getFastMathFlagsOrNone,
#200457).
To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications
More information about the All-commits
mailing list