[all-commits] [llvm/llvm-project] 2f4c38: Move KCFI type ID hash helpers out of LLVMSupport ...
Fangrui Song via All-commits
all-commits at lists.llvm.org
Sun May 10 10:26:56 PDT 2026
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 2f4c387147f1617e242dd500960410728e5ec35e
https://github.com/llvm/llvm-project/commit/2f4c387147f1617e242dd500960410728e5ec35e
Author: Fangrui Song <i at maskray.me>
Date: 2026-05-10 (Sun, 10 May 2026)
Changed paths:
M clang/include/clang/Basic/CodeGenOptions.h
M clang/lib/CodeGen/CodeGenModule.cpp
R llvm/include/llvm/Support/Hash.h
M llvm/include/llvm/Support/xxhash.h
A llvm/include/llvm/Transforms/Utils/KCFIHash.h
M llvm/lib/Support/CMakeLists.txt
R llvm/lib/Support/Hash.cpp
M llvm/lib/Support/xxhash.cpp
M llvm/lib/Transforms/Utils/CMakeLists.txt
A llvm/lib/Transforms/Utils/KCFIHash.cpp
M llvm/lib/Transforms/Utils/ModuleUtils.cpp
M llvm/unittests/Support/xxhashTest.cpp
Log Message:
-----------
Move KCFI type ID hash helpers out of LLVMSupport (#196784)
PR #167254 inappropriately introduced llvm/Support/Hash.{h,cpp} for the
KCFI helpers. The name is misleading — it has nothing to do with the
generic hashing facility in llvm/ADT/Hashing.h — and KCFI is a
CodeGen/IR feature that does not belong in the foundational Support
layer.
Move the files to llvm/lib/Transforms/Utils/KCFIHash.cpp, alongside
setKCFIType, which is the only existing KCFI helper in TransformUtils.
Also relocate the deprecated pre-xxh3 xxHash64 implementation into
KCFIHash.cpp, the sole user. clang/test/CodeGen/kcfi-generalize.c and
kcfi-normalize.c are end-to-end regression tests for the xxHash64 output
To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications
More information about the All-commits
mailing list