[all-commits] [llvm/llvm-project] 2d5abf: [orc-rt] Change SPS controller-interface naming co...

Lang Hames via All-commits all-commits at lists.llvm.org
Mon May 4 21:04:03 PDT 2026


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 2d5abf3f44eb8c8f4c5172638af69c962da96560
      https://github.com/llvm/llvm-project/commit/2d5abf3f44eb8c8f4c5172638af69c962da96560
  Author: Lang Hames <lhames at gmail.com>
  Date:   2026-05-05 (Tue, 05 May 2026)

  Changed paths:
    M llvm/lib/ExecutionEngine/Orc/Shared/OrcRTBridge.cpp
    M orc-rt/include/orc-rt/SimpleNativeMemoryMap.h
    M orc-rt/lib/executor/sps-ci/MemoryAccessSPSCI.cpp
    M orc-rt/lib/executor/sps-ci/NativeDylibManagerSPSCI.cpp
    M orc-rt/lib/executor/sps-ci/SimpleNativeMemoryMapSPSCI.cpp
    M orc-rt/unittests/BootstrapInfoTest.cpp
    M orc-rt/unittests/MemoryAccessSPSCITest.cpp
    M orc-rt/unittests/NativeDylibManagerSPSCITest.cpp
    M orc-rt/unittests/SimpleNativeMemoryMapSPSCITest.cpp

  Log Message:
  -----------
  [orc-rt] Change SPS controller-interface naming conventions. (#195614)

This commit makes two changes to the naming conventions for SPS CI
symbols:

1. The orc_rt_sps_ci_ prefix is replaced with orc_rt_ci_sps_ (for SPS
wrapper functions) and orc_rt_ci_ (without the "sps_" suffix) for data
symbols.

2. The _sps_wrapper suffix is dropped from wrapper functions, since the
prefix now distinguishes between SPS-wrappers and data symbols.



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list